删除早期版本的Netscape 4中的HTML JavaScript实体。

原型

wp_kses_js_entities( string $string )

描述

以前,此功能是从原始导入的kses中删除的,并删除了仅在早期版本的Netscape 4中存在的特定漏洞。但是,此漏洞从未影响任何其他浏览器,并且可以被认为对现代Web安全。

参数

$string (string) (Required)

返回值

(string)  

源文件

路径:wp-includes/deprecated.php

<?php
...
function wp_kses_js_entities( $string ) {
	_deprecated_function( __FUNCTION__, '4.7.0' );
	return preg_replace( '%&s*{[^}]*(}s*;?|$)%', '', $string );
}
...
?>

其他

英文文档:https://developer.wordpress.org/reference/functions/wp_kses_js_entities/