服务器是否运行早于1.5.0版本的lighttpd?

原型

is_lighttpd_before_150()

返回值

(bool)  服务器是否正在运行lighttpd <1.5.0。

源文件

路径:wp-includes/functions.php

<?php
...
function is_lighttpd_before_150() {
	$server_parts = explode( '/', isset( $_SERVER['SERVER_SOFTWARE'] )? $_SERVER['SERVER_SOFTWARE'] : '' );
	$server_parts[1] = isset( $server_parts[1] )? $server_parts[1] : '';
	return  'lighttpd' == $server_parts[0] && -1 == version_compare( $server_parts[1], '1.5.0' );
}
...
?>

其他

英文文档:https://developer.wordpress.org/reference/functions/is_lighttpd_before_150/